How can I improve Broken Link Checker?

Set a propper UserAgent for BLC

In http.php file (modules/checker - directory) is a useragent set. Please set it to a string that could be identified by statcounters. Seomthing like "Mozilla/5.0 (compatible; BLC/Broken Link Checker; http://wordpress.org/extend/plugins/broken-link-checker/)".

The reason is very simple. I just wondering why my server crawles my site and identifies itself as IE7 on WinXP. First I thought I got hacked. It takes a time to find this in BLC.

This change is a minor in http.php in two lines - 142 and 345 - but it will prevent confusing the admin :-)

Cheers

14 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    ppfeufer shared this idea  ·   ·  Admin →

    0 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...

      Feedback and Knowledge Base